APR chip malfunction?

Hi all,     Had my 2000 A4 1.8TQ in for my oft-engaging engine check light. Again the codes were for MAF meter and they changed it.
I just picked it up and when the turbo spools up in 2nd and up gears, it sounds totally unlike before - very loud and clear (as if someone hit the heater fan on full) and the car flies. But I feared that's not good. So I pulled over to shut off the APR chip via the cruise stick to see if it ran regular with the chip off, but I don't get a blinking check light in either speed to select on or off. Is my chip and/ECU fried? Am I likely to have to send this ECU off to APR? Any thoughts? Thanks.
--
- Kyle

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well, after a 40 mile ride to work and shutting the car off, I retried selecting the chip EMCS program and it worked. ???? The turbo is still noisy - and flies - so I'm taking it to the local APR dealer in Londonderry, NH today to have it diagnosed. They said I can upgrade the chip to the latest software for $95 as well. Can anyone say if it would be worth it for any changes in code since 2002? Thanks.
--
- Kyle

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.