Audi A4 Tempremental starter

I have an A4 which regularly, over the past few years, has become a bad starter.
1.8 (110,000)
Engine turns over well but won't fire.
Can't see any pattern - leave to stand or persistence seems to get it done
but Missus not very happy.
I think a cure would be better than a trade-in (and cheaper).
Non-VAG garage says he can't find nothing wrong - any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

start by changing the cheap stuff, plugs, leads etc. If that does not correct the problem then 30 on an ECU check might be worth the money. Though this does mean car is off the road for 4/5 days. A garage VAG check would cost much more but the car remains operational.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Steve, Did the "non-VAG garage" pull the error codes from the engine management? No patterns like following a period of hard driving, rain, refuelling, etc.? How old is the battery/wires/plugs/? Cheers! Steve Sears 1987 Audi 5kTQ 1980 Audi 5k 1962 and '64 Auto Union DKW Junior deLuxes (SPAM Blocker NOTE: Remove SHOES to reply)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Very likely a bad G62 Coolant Temperature Sensor.
My two cents,
JP Roberts
P.S.: Had the same symptoms.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.