Audi Idiling

I have a 99 A4 2.8 non quattro. I have noticed when I first start the car in the morning the car idles at 2000 RPMS an then when it gets warm it drops to 1000 RPMS. (I live in Phoenix too so it never gets
cold) Car drives great but shifts funny. If I am goin 80 mph on the highway car would be at 4000 rpms. I know this is not normal, but looking for some advice to see if this is a major transmission job that needs to be done.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

what is the temp at 'cold' start.
the idle appears a little high in both cases.
80 should equal around 2500 rpm in 5th.
yes sounds like you could still be in 4th and have a shift problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Normally when I start the car in the morning it's around 70 degrees outside. Car is automatic if that helps also. Would tune-up help or what options am I looking at?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

it certainly sounds like some sort of diagnostic needs looking at.
the box must have a form of electronic control as I believe they learn the way an individual drives......well mine seems to.
dj 98 2.4 SE Auto in the UK.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.