Audi Instrument read out disabled (UK)

Hi,
Purchased a UK 2001 Audi TT from the Auctions. Unfortunately the instrument panel appears to be dead. The ABS and other lights appear then disappear
when the ignition is turned. But the fuel, temp gauge, rev and mph counters are not working. A yellow circle appears and stays in the centre of the console.
Anyone know what could be wrong?
The battery was probably completely dead for a long time.
TIA,
gbnews
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's not unknown for the instrument panels to fail, but it would be worth removing it and checking all the connections at the back. Next step (or maybe even the first step) would be to connect up a VAG-COM, or other diagnostic computer, and see what faults are reported for the instrument panel. Do the clock and odometer sections not come on?
I take it that the car actually runs - I think that the immobiliser is coded through the instrument panel, so if it were completely dead, then the engine wouldn't run.

Probably not significant.
If you're in easy reach of the Reading area, I would be happy to look at the fault codes for you, using my VAG-COM.
--
Peter Bell (Note Spamtrap - To reply, replace 'invalid' with 'bellfamily')

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.