Central Locking '97 A6 2.8Q

The central locking on my car appears to work fine remotely, in that all the door locking knobs go up and down and the small light in the drivers door knob flashes etc.
Recently when unlocking remotely the drivers door it would not open with the exterior handle so I had to open from the inside. This would only happen intermittently.
More recently when the door was opened from the inside with the chrome handle it made a fairly loud metallic click when opening. This remained for a few days although on these occasions it was opening fine from the outside and the central locking itself was fine.
All of a sudden the problem corrected itself and the door opening mechanism sounded like it should and didn't put up as much resistance.
Yesterday it returned to making the clicking sound on opening while having to really pull on the handle more than normal.
Tonight I locked all locks from inside as I always do if in a dodgy part of town and when I got home I couldn't open the door from inside or out. The central locking works remotely as normal, all knobs go up and down and the set light flashes but I can still not open the drivers door at all now, it seems to have totally given up the ghost.
I do have some kind of non-Audi warranty so I will have to look further into whether this is covered or not. They covered a similar fault on my old Passat 1.8T when one of the door lock developed a problem with one of the micro switches.
I have searched the archive and can see that a whole range of faults can occur but cannot find a symptoms like those befalling me at the moment.
Any advice would eb welcome before I take it into the garage tomorrow.
Ray West Yorkshire UK

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.