Central locking system randomly locks and unlocks doors - 1999 A4 Audi

Hi,
I have several problems with the central locking system and alarm of this unmodified 1999 Audi A4, which may or may not be related:
1. The central locking system will lock and unlock doors at random.
This can happen when the car is moving, parked, or unattended parked!
2. A problem linked to the locking system occured yesterday at a gas station. I would unlock the doors, and the doors would immediately lock again (including the gas door) - so that I could not fill up the car. The problem was solved by asking someone to stand by the gas door and quickly opening it while I was pushing on the unlock button on the driver side door.
3. The remote control keys don't work, and I am unsuccessful at attempting to reprogram them.
4. The alarm system blinking light does not light over 90% of the time (it has lit only once recently).
5. The trunk lights don't work when you open the trunk. I add this info in case the problems above are caused by a malfunctioning switch detecting the status of the trunk closure.
Has anybody experienced these problems... What should I look at or test to troubleshoot the problem and fix it? I only have a voltmeter for now...
Cheers!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Take the key fobs away from the general vicinity of the car (100 ft or so) and, one at a time, bring them to the car and work the locks. Does it do it with one and not the other? If so, you may have a bad switch on the key fob that is causing the doors to lock.
Ken

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
X-no-archive: yes 1970 Suzuki TS250 wrote:

I had this on my 97 A3, it needed a new central locking pump (a whopping 230 uk pounds - $400) to fix.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Graham wrote:

"Pump"? This stuff isn't electromechanical?
-- Mike Smith
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 31 Jul 2004 15:32:15 -0400, Mike Smith

well, yeah - electropneumatical to be exact...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mike Smith wrote:

Thats how it was described on the invoice.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's vacuum operated, or it was on my old VW car!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.