Ignition Coil Pack - A6 2.0l

Just had a complete replacement of all 4 ignition coil-packs on my Mar 2002 A6 2.0 after I went drive it this morning and there was bad engine vibration, lost of power and the yellow Engine Management light was on.
Had _exactly_ the same failure in late October 2003 (9 weeks ago) and my dealer only replaced the faulty one. When it failed again this morning, I was attended by Audi Roadside Assistance (UK) and the technician swopped the other three with the latest revision. He told me there were three engines badly affected the 1.8, 2.0 (and I've forgotten the third). he also said that Audi dealerships were doing a product recall during routine servicing and exchanging the coil-pack as and when the cars come in for their annual check.
Anyone else with the same problem ?
August
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The third engine affected by faulty coilpacks is the 3.0 V6.
I didn't have any CP failures on my '01 A4 1.8TQ, but regardless, dealer replaced all 4 of them with an updated CP design last June, as part of the recall campaign.
Last winter, the CPs on the 1.8T and 3.0 engines in the US (2.0 not available there) were dropping like flies on VWs and Audis. I'm sure it was the same in other countries as well. Finally, VAG got so much bad press about it, that they decided to do a recall of the affected batches (2001 and 2002 model year mostly).
Cheers,
Pete
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.