Immobiliser issue...

Hi
I was coming back from work today but couldn't start the engine, as for some reason the key or the immobiliser had lost it's code! The engine did fire up but immediately died, and the immobiliser light
started flashing.
Fortunately, I had another key with me! I could start up with that key, and then the other key started working.
Does this happen often? And any idea what could have caused it? I don't really want to carry around two keys just in case! :)
James
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Happened to me in my A3, had to get the key barrel changed. A short term fix that worked for me was when the engine died with the flashing immob. light is to remove the key, wait 2 seconds, re-insert the key and it should fire up.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Mine has done it 3 times now since yesterday, seems to be about 50% of starts! Guess it could be a loose harness or something. No fault codes are being logged though. Anyone got any idea of what I could look for? I don't want to keep going back to the garage :)
James
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Its the key barrel on its way out. Very little option but to replace to cure the problem. I did and the problem has gone 100%. IIRC mine didnt have any fault codes either, but there you go.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

tends to have a dodgy connection after about 3 yrs of ownership, it is a very common problem and costs around 150 quid to fix, btw im in bristol also :)
Just wiggle the key a little and it will be fine, but do get it fixed unless, like me you have better things to spend 150 quid on, if it quits totally I will just get it towed to a dealer and fixed...
Ron
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Great - thats what I saw on Etka, I found the part number I need already :) Give me a shout if you need to borrow my vag-com for anything, although I suspect you're sorted in that department!
I am going to try and get this done under warranty (not audi warranty - warranty given by garage)

Hopefully it won't be my 150 quid :)
James
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.