P1128

CEL code has been on forever it seems, I just replaced timing belt system, water pump, turbo line hose, vacuum hose, check valve, and front brakes and rotors.
I have a 2000 A4 1.8T Quattro, Auto tranny, 79,000 miles. Wondering if this code which did not come on for 150 miles right after I replaced the hoses and check valve is due to a faulty MAF sensor.
Where is this sensor located? How to i remove and install? Also, why do Audi dealer's never want to replace this because we are given extended warranty? So they diagnose other problems and let you pay for that so you don't get free labor and they have to lose possibility of labor charges.
Need help.
Seweryn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have a read of this thread: http://www.passatworld.com/forums/showthread.php?t 9165&highlight=p1128
There's loads of other stuff about your CEL there too.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Alec wrote:

wow very imformative, thank you, i am actually walking out the door to a 1.8T engine specialist who said may have an extra MAF from an previous engine, we are jsut going to switch them out, then I will reset the light if i can, if not then just unplug battery, and drive another 50 miles to see if it comes on, if not then hooray, i can go take a smog test.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.