Premature oil pump failure 01 A4 1.8T

A friend just had an oil pump failure on his 01 1.8t at 52K miles. Car has been maintained properly and has not been driven wildly either by him, or his teenage kids. Audi has diagnosed the problem as a failed
oil pump and not abuse so it sounds like a defective pump. Has anyone else experienced this, or know of other cases? Given the mileage, Audi is claiming the problem is out of warranty.
Thanks
Henry Boyd
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Never read it before but it really feels like Audi should cover at least 50% of the repair. Shouldn't they cooperate, if it were me I would be terribly disappointed and would never buy one again, but then again I would fight with claws to get it sorted out by the dealer, after all we're supposed to be buying German quality cars, so if they admit the pump was defective and it's just a '01 baby, it's a matter of self-dignity for them.
My two cents,
JP Roberts

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

50%
Its usually a matter of money I'm afraid and dealers (certainly here in the UK) are not generally renowned for doing much else other than taking lots of it. That said a lot of them seem to be being bought out by VAG at the moment.....
I.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.