rough idle on 98.5 A4Q 2.8

So, my car idles a little roughly, not too bad, but I really would like to smooth it out. It's got 99,100 miles on it (98.5 A4Q 2.8 for those who didn't read the Subject header), and I put in a quart of a
valve and injector cleaner recommended by my independent shop recently (went through a tank and a half of gas on it, as recommended), but the idle isn't much better. Am I doomed, or do I need to lather, rinse, repeat with this stuff, at $30 per quart?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did your repair shops diagnostic check not show any problems or error codes?
Steve.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 15 Jun 2006 00:01:30 +0100, "Steve68s"

The diagnostic check showed no problems, no error codes, and the manager thinks the injectors may be slightly plugged, hence the fuel additive.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 96 with the 2.8 does the same thing. If you find a solution, please post.
Cory
KLS wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Your MAF might be dirty. There are ways to clean it if you look on some of the forums like AudiWorld or MotorGeeks.
cory1210 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.