slugish a4 1.9 tdi

i have an a4 tdi 1.9 and it seems to be loosing on acceloraition when i get to 60 and put my foot down it seems to hold back and slowly speeds up has
any one got any ideas cheers craig
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
looneytoons wrote:

Unplug the MAF (in the air inlet trunking). If it is no worse with it unplugged, replace it. Other than that? Get the codes read with VAG-COM.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
just had a mas air unit as i was told that was the problem but no change but cheers anyway
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
looneytoons wrote:

In that case, get a code reader (preferably VAG_COM) on it, and look here:
http://forums.tdiclub.com/showthread.php?t 9589
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

get
has
Did you check the vacuum hose which goes to the turbo? I had the same problem, the hose was damaged by a mounting bolt of the turbo. If not then maybe the variable nozzel (VNT) inside the turbo is stucked. If it is stucked I suggest you to let it cleaned before replacing it. You'll find alot of information on the internet about it.
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.