TT instrument cluster dead

Does anyone know if Audi has recalled or otherwise replaced gage clusters for TT? Mine is dead and I can't believe I have to pay for a new one. Thanks in advance!
2000 TT Coupe.
BTW Bridgestone Turanza tires are very quiet.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

seems common to a few Audi models. My A4 1997/8 is getting weaker and gradually disappearing. There have been a number of posts here on this problem.
dj
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ted wrote:

My 2000 TT has died a few times some sort of electrical short in the system the dealer says they have traced all wiring and have found zip they just keep giving me a new battery and send me on my way.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you for responding. At first just part of the gage cluster did not work, so I did put in a new battery and that fixed it. Now it does not work, new battery or not.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

new battery..............is this a dedicated instrument cluster battery and where is it. mounted.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not a dedicated instrument cluster battery. Its the big one under the hood.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Overpriced Volkswagon!!! Ha!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.