Turn Signals

I have an 2001 A6 2.7T and recently ran into a problem with my turn signals. All of a sudden, they don't workanymore. When I engage the signal,the lights d not blink <signal> but when I check outside the car,
the lamp on the side that I switched to is on, ut notblinking.
First thought was to change the fuse, but when I putin a new one,it still would not work.
Questions, what, other than the fuse could be causing this ?
Any help appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 06 Nov 2012 07:31:50 -0600, against all advice, something

It's your emergency flasher button. Same thing happened with me '04 TT.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

The emergency flasher is working, that was the first thing I checked. How did you fix the problem ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 07 Nov 2012 08:11:21 -0600, against all advice, something

I took it to a dealership, and they replaced the flasher button. It's a well known problem. Dude had it diagnosed from the same description you are posting here.
--

Having Mitt Romney at your cocktail party is the social equivalent of two people
not turning up.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Steve,
Thanks. I took it to my mechanic and he said exactly the same thing and even knew the cost of the part. Will be taking it in tomorrow to have it fixed. Thanks again.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.