1988 325 e alternator

replace alternator and a new battery ,but for some reason new alternator is not charging battery,it drains all its power after a few days ,checked all
wires coming out of alternator...everything tight...does this car has a voltage regulator..pls any advise will be apreciated ..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The voltage regulator is normally on the back of the alternator.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'd like to hear how you got the old one off and new one on w/o issues. It sounds like you have some component draining the battery. Is the alternator belt aligned correctly ? any skeaking etc..
John G.Burns B.Eng, Bonny Scotland

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

is
Mine was a bulb that fell out behind the instrument panel. The batt indicater bulb that you see on start up....usua red.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Nicik Name wrote:

Sounds about right. Hope he did not replace a perfectly good alternator and battery when all he might need is a bulb.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.