1998 bmw 740il windshield wiper gone crazy!!!

The other day it was raining very heavy and the windshield wipers worked fine until I parked and hurried out the car leaving the wipers in the on position. The wipers did position itself in the middle of
the windshield to remind me it is being left in the on position, but I just left them that way and ran thru the rain. When I returned to the car a few hours later the wipers would not return to home horizontal position; at the bottom of the windshield. Instead it would terminate at the center vertical position no matter what setting it is on, or even when I shut it off.
I would like to know if there is an easy fix for this problem or if anyone had this problem b4 and know the fix for it. Any help is appreciated, thank you!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On May 18, 2:26am, snipped-for-privacy@gmail.com wrote:

Typical example of that wonderful kraut electrical engineering/ get used to it. There'll be many more things like this.

Sorry, but never ran into this particular problem. It could be a simple thing like a bad capacitor, but you have no way of knowing which one or where it is. Your friendly local stealership will be glad to find it and hit you for $500 for replacing it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.