1999 735i trunk lid opening mechanism

Hello all,
if any body has any spare time, any help would be appreciated in telling me how to fix the opening mechanism on my trunk lid.
The hydraulic system is only working intermittently. When it does work,
it will sometimes only open the boot lid partially before stopping. The red 'push to close' button on the lid is also not illuminating at the same time that the hydraulic system doesn't work. It seems to work more often when the car has been running for awhile than when it has not been running ( but this may just be coincidence). The locking servo works fine (seems to be a separate circuit). I do not know where the electronic controller or hydraulic motor/reservoir is installed, or where the fuse is.
These are all the clues that I have. If somebody could tell me how to test the motor from the control box I would know where to start trouble shooting.
I would like to put my wife inside the trunk to help me trouble shoot but am afraid that it may start working again!
Many thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 22 Apr 2006 09:42:34 -0700, user1 wrote:

Well, I can't tell you what's broken but I can tell you that these are the parts:
http://realoem.com/bmw/showparts.do?model=GG41&mospidG513&btnrA_0075&hgA&fg `
And whatever you suspect as faulty, the parts can be gotten from www.bmaparts.com.
Sorry I can't be of more help, but I don't have experience with that model.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.