525i 1992 Speedometer and RPM meter problem when cold outside

Hello all,
I've a problem with my '92 525i when the tempratures outside drop to around freeze point. The speedometer and RPM meter start jumping around, or stay at
20km/h 500 rpm. When the car has heated up and I stop it for 2 minutes or so the problem is gone.
Does somebody know what the problem could be?
Thanks and best regards, Marcel, currently at 341K km.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

around
at
so
Replace the 2 'AA' nicad batteries on the dashboard printed circuit board. Fairly well documented procedure.
JB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Marcel Vollebregt wrote:

It may be the bearings in the gauge not being lubricated well enough. It's a major pain to pull them and drop in a little oil but that may be what it needs. I had a similar problem with my speedometer for a while but it seems to have cleared itself.
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hello all,
I didn't find any batteries inside my dashboard. I did the following thing: http://home.online.no/~st-arhol/enge32speedo.htm
I replaced all electrolytic capacitors (6 in total), one measured bad the one close to the orange capacitor/transistor, not at the regulator.
It has not happended yet, so if it won't happen again troughout the winter. It's the fix.
Best regards for the response!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.