633csi won't start

Hi, I'm new to this so I hope I do this right. I've got a big problem with my BMW 633csi. It won't start. A couple of days ago it turned over, now it won't
even do that. The only thing that happened was that when I was looking around the engine area, I noticed a hose that wasn't hooked up so I found a place on the starter where I thought it went and hooked it up. After that, nada, ziltch, nil, nothing. WHAT DID I DO? I have been hopelessly looking through the Chilton Book and searching every website I can get my hands on, but still am no where near finding the solution then I was days ago. At first I would have bet my bottom dollar that it was the starter but now? There are so many things it could be and too many places to look to say for certain what it is. I desperatley need help with this problem. I am a single woman who is trying to be independent and fix things on her own but somethings just are way beyond my reach and this is one of them. Many, many thanks to all who can and will offer their help.
Desperate in California Debbie M.
--
seahwkfan

------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bad park/neutral inhibit circuit of it's an automatic.
Bad ignition barrel.
Flat battery?
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
John G.Burns B.Eng, Bonny Scotland

I go with John ?? flat battery!! Fitzy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.