735i '85 failed smog

The engine has been running rough at idle for a while and the tail pipes have been a little dark as though it is running a bit rich. It failed the smog test on NO.
I will be changing the plugs tomorrow and starting the check of the other laundry list of things that might be wrong, but the guy who wants my money just keeps saying it is the catalytic convertor.
Any comments?
JJ
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well, it could be the cat, but you need to look for air leaks in the intake system, including all the hoses and tubes, first. The cat is the *last* thing you should replace. A plugged cat may indeed cause similar symptoms to intake system air leaks, but a good mechanic should be able to diagnose these problems separately.
Floyd
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Change the oil and don't put too much in. Tweak the injection to optimal. Gap or change plugs, change air filter & other routine service items. Go for a longish steady run just before the test.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"R. Mark Clayton" wrote:

Tnx
JJ
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

he is right- --------

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.