87 325 I - Passenger side electric window problem

I'm new to this car. The passenger side electric window will not go completly up. tried the safety switch, but it's something else. Are the window motors on fuses? any help would be appreciated.
tia,
lance
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Lance Reichert wrote:

Maybe the window just need to be adjusted. Does it bind in the frame so it get stuck?
--
BBO, DoD#2101

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

is the window "square" in its tracks?
Look for obvious things like obstructions in the tracks, wrinkled seals etc.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the ideas guys.
The window seems to be "on track".
I think this is an electric / motor problem. There's no hum or sence of resistance when I hit the window control button.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Gosh, Lance, noone local here in Seattle could help you?
FloydR (in Renton)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like your motor is weak. Fuse is, oddly enough, next to hazard button.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have the same problem with my 89 325I-passenger window won't move, back windows having a problem too. The back windows go up only by using the switch on the back doors-could the front switches be worn out?
Lance Reichert wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'm in Seattle and my 84 E30 318i windows just quit both at once too...
I've seen this problem in a few places googling the net but no one has a solution.
Doesn't seem to be the fuse... worked fine last night when I parked it!
I found a wiring diagram but I'm not positive mine is exactly the same, but it's close: http://bimmer.roadfly.com/bmw/forums/e30/5443604-1.html
Best of luck to all!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.