87 bmw 325e heater is not working

coolant is full, tepurature is normal, used air to blow out heater core, does not seem clogged,removed glovebox and checked for blend air door movement, blend air door seems to be moving. what am i over looking

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sm357 wrote:

Needs to be bled likely.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Heater control valve. It on the left side of the console just above the vent that blows on your feet. Common point of E30 heater problems. Just had mine out on Friday, tried to fix it as I know it's the problem (it was FULL of gunk) but it's still not flowing water. Haven't bled the system out yet so I might have got it.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
So when you say that the heater core does not seem to be clogged do you mean the air passages thru it don't seem to be clogged or do you mean that you have tested the fluid path and it's not clogged. The symptoms you note and the age of your car seem to point to a heater core with clogged fluid passages. You really have to remove the core to see if it's clogged by pouring water through it under the faucet. Next suspect would be the solenoid water valve thats in the supply line to the core. It works on 12 volts and you can check it by jumpering it to the battery while you have it out.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.