91 old shape 316 wont start

Hi.....316 wont start. turns over fast. fires now and again but wont start. The drum 'thing' under the car nearside in front of the rear tyre was tapped....then it fired...ran...and stopped.
Any clues?? M4CKK
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like a bad fuel pump or it's relay. The relay lives in front of the windscreen under a long black plastic strip. The relay next to it is the motronic relay. They cost a tenner each, it's worth replacing both. If you give the relay a good thump it may cure it temporarily.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Agree with John, but it sounds like you're discribing the fuel filter when you say the "drum thing in front of the rear tyre"; so if tapping that temporarily eased the problem, that also could be the culpret. They are cheap to replace so it may not be a bad idea to do so, if only to eliminate it. -- Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ive tapped the relays (didnt know they were there) smell of petrol in engine bay....still wont start......Where is petrol pump?? Cheers, M4CKK

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Petrol pump is under back seat....
http://www.esatclear.ie/~bpurcell/318ismaintenance.html#fuelpump

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The petrol pump is working....does that mean that the relay is OK ?? How much are petrol filters??
Cheers..........

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hmm,if pump is working than relay is also working,try to disconect fuel hose after fuel filter if fuel comes out whan you give a contack than something else is problemm,maybie IMPULSGEBER??!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Still no joy.........!!!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.