a weird noise from my e39 528 (manual)

Well, it's been almost a full 2 months without something going wrong!
I noticed a week ago back that at 70mph, particularly on smooth roads, there seems to be an odd noise coming from what i think sounds like the
rear of the car.
Sounds almost like tyre noise...I think.
It's a low frequency humming/rumble....but you can't feel any vibration.
It is most noticeable at 70mph on smooth tarmac. I think that when accelerating, the engine noise overpowers the other sound, as if you coast down from 70mp to 60mph the noise gradually fades away. It doesn't seem to do it at speeds above 75mph - could be that over 70 the wind noise dulls it out.
It's not really loud, I mean, even the stereo on very quietly means you can't hear it.
I've got new tyres on, and the car's been lowered recently on eibach springs (30mm front/25mm rear) and aligned properly.
I don't *think* it was doing it before I lowered it, but then i don't do motorway driving that often, and if I do, it's normally the same 85mph as everyone else.
I've had a mechanic sat in the front and the back of the car having a listen (I thought it might be coming from the rear), but whilst he could hear thse noise, he couldn't pinpoint where it was coming from and didn't think it was a wheel bearing.
The tyres don't appear to be wearing funny either.
The car's being taking the the Nurburgring in April, so I'm even more keen that usual to find any noise sources.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.