abs and traction control both lit - help!!

I have a e39 bmw 520i - the car was stood on the driveway for sometime. I then took it for a spin and left on the driveway again. the next day both the traction control light and the abs light remain lit when
driving.....does anyone have a clue what might be causing this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Bad speed sensor in one of the rear wheels?
Eisboch
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the wire coming from the ABS sensor in the wheel well. The lights would come on whenever it was wet outside. I figured it must have been a short so I started tracing the wires and discovered that a plastic cover at the point where the wire entered the front left wheel well was open. It was so caked with dirt that it must have acted as a wick whenever it rained thus shorting out the ABS. No problems since cleaning it up and snapping the cover closed. Since the ABS and traction control work in conjunction with each other I'm not surprised a problem with one affects the other.
It could be a number of things but I'd start with checking the ABS sensors and the wiring.
- Erik
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.