Alternator/Regulator question

I have a 1994 318i with US specs that I recently purchased from a private owner and would like a little help from the group to diagnose an electrical issue.
* The alternator appears to be a 105A Valeo * Most of the time (but not all the time), I notice a slight pulsating of all lights - headlights, odometer LEDs, interior lights, etc. * The pulsating is sometimes made worse by increasing the electrical loads, sometimes not. * Every now and then, the backlight for the onboard computer display will go very bright for 2-3 seconds and then the instrument cluster will go dead and reset itself. * Sometimes the check engine or ABS fault light switches come on briefly and turn off.
Based on posts here and elsewhere, I suspect the voltage regulator or alternator. So, I did a load test in the car while measuring battery voltage:
At idle: ~14V All electrical loads on and at idle: ~12.6V All electical loads on and at 2000rpm: ~ 14V
Does anyone have any insight into whether it is the alternator, regulator, or both? Also, I understand the Valeo alternators are not very reliable. Should one even bother fixing one or just replace it with a Bosch?
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
waffled on about something:

The voltage's don't look bad, but given the pulsing you describe, it does sound like the regulator might be playing up.
However, before you go shopping, check the battery fluid level, clean up the posts and re connect, then do the same for the battery earth connection to the body and the engine earth strap.
Dodgy.
--
MUSHROOMS ARE THE OPIATE OF THE MOOSES

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.