BMW E39 OUTSIDE TEMP. SENSOR

Hello everyone!! I have a E39 (2001), the outside temperature display is reading over 100F all the time.. it all started after a rock hit under the car in
the area of the frotn right tire (dnt know if it has anything to do with it..???) but after that moment the temp. is just way off.. does anyone know where the temp. sensor is located? or what could be causing this problem?? how to change if that was the case... thanks for any help you can provide.. -Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The sensor is located in the right front wheel well area. After mine was damaged it read -40 (in southern California).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Pepperoni Pizza wrote:

Thanks very much.. it is in that area where i had a problem.. so maybe the sensor is broken.. Im reading 118F in the middle of the winter here in NY do you know what does it look like? and would u know where or how to get that part?? or do i have to go to the dealer directly??? -Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Are you sure this isn't just another good example of the effects of global warming?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I suspect your hit caused the sensor to fail and read near maximum (when it's disconnected or fails outright it reads -40F).
It's located right behind and below the front bumper/spoiler (bodywork) far right side in a slight indentation in the black plastic. It's a pretty simple R&R. You'll have to get the part at your local stealer.
R / John

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.