BMW X5 Clicking noise

Hi - My X5 3.0 started having this clicking noise and when I checked the oil it was really low. I added enough oil but the sound is still there. Has anyone experienced something like this?
btw: the reason I checked the oil, although I did not see the low oil indicator lamp, my wife said she saw it yesterday illumunated - and I thought after adding oil it should go away, but it is still there...
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check it again, if you are loosing oil you are probably in big trouble.
All sorts of things could be clicking, but it is most likely the hydraulic tappets. This should go away after a few minutes [light] use.
OTOH if anything has become worn through lack of oil...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Is it a low oil indicator lamp or a low oil *pressure* lamp? There is a big difference. Vast difference. A chasm. Of huge proportions.
Huw
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ok - so I took it to the dealer yesterday and it looks like they think it is the alternator pulley that is making the noise - i brought it home before they do any repair to get a 2nd opinion and when i compared the pullys of this car with my other two cars it looks like there is no enough tension and the pully is loose here. You can almost see the movement to the side as it revolves. Anyone else has seen this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
juma gul wrote:

So it is the charge warning light that is lit?
Huw
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No, nothing is lit now.....but the movement of the pully is not sold and I see that it has lost some of its tension and it is loose...
Huw wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No, nothing is lit now.....but the movement of the pully is not sold and I see that it has lost some of its tension and it is loose...the car is at the shop, let's see if that is the final verdict...
Huw wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.