Brake Lights

Hi to everyone,
Just noticed that all brake lights are not working on wife's 95 316. I did check the fuse & it looks OK. Any hints what to check next, please?
thanks jerry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The bulbs?
I once wasted half a day tearing things apart to get at the wiring, only to discover that both bulbs had failed more or less simultaneously.
--
Dan.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dan, bulbs look OK..also hatch break light is out.
thanks jerry
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace the fuse. Sometimes they look OK, but they aren't. They are cheap too.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Do you mean, besides the lights themselves?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, wasnt sure how to track the problem? jerry

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
if it is a touring, then check the cables and wiring from the body to the hatch, likely worn through somewhere///
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.