Brake noise

I have a 2005 Z4 which I drive a couple times a week. When backing up I notice the breaks make a loud grinding noise as they are applied and released (car moving slightly with breaks applied).
Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Could be the incorrectly fitted bolts backing out, some gravel, or the brakes simply not fitted properly.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Since the problem corrects itself it cannot be the bolts or incorrect fitting of the brakes. And given it happens all the time I would assume it is not some gravel.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If the car is parked up a lot in damp weather (UK this summer?) then rust will form on the disks.
The first time they are applied you will hear this being ground off.
This will be more noticeable if the brakes are applied when running slowly and in reverse (e.g. after backing out of the garage).
Diagnosis - correct operation, although you could be getting near the end of the pads.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks. I think I will take it into the shop. However, the weather is not damp here at all (no rain from April through Sept./Oct. And given there is only 12500 essentially highway miles on the car I hope I am not at the end of the pads already.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.