Check engine light -- O2 Sensor 92 735i

Last month -- my check engine light came on -- the code was "llamda sensor" (o2 sensor) -- so we replaced it.
It seemed ok -- but then i t came back
Here's when it comes on: If I start the car & let it idle -- it will come on & cycle on and off -- with no consistency.
if I touch the throttle - it goes off right away; by "touch" I mean give the engine some gas, but not much; barely enough to change the tach.
if I leave it alone; it will go off on it's own; but then go back on.
Driving it never comes on.
Some suggested that it's in need of a valve adjustment (the knew we replaced the headgasket 4 months ago and didn't re-adjust the valves afterwards -- we couldn't see a reason to...)
What could be causing the CEL to come on at idle? The only code the reader is pulling is the o2 sensor.
Typically the idle gets rough right before it goes on.
Thanks -josh
--- AntiSpam/harvest --- Remove X's to send email to me.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oh _llamba_.
I thought it was warning of an impending collision with a llama.
Lovely creatures llamas.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.