Computer says engine oil low

Hi,
Have a 1990 525i. The after a long trip of about 40 min. (now it did it the other day after only a few miles) the computer will flash "Engine Oil Low". Get out, open the hood, check the dipstick, reads
right in the middle of add and full. What gives? Computer sensor broken? Help!
Thanks, Joe
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Old engine (lots of sludge), give it a bit of a thrash down the motorway and it pumps lots of oil into the head, pull off or just lift up and the sump settles and the sensor detects low oil.
Put about half a litre in.
Maybe next time you service it ask about different oils and consider having it flushed out (e.g. with "Gunk").
If you do DIY oil change with the ignition on, it will notice and remember that there wasn't any!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 2003 E39 530 light will come on after 5000 miles ... like clockwork. I add 1/2 qt., & all is fine.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'll do the flush and add the oil. Thanks. Joe
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.