dash fault

Has anyone ever had a problem with the mileage disapearing and being replaced with 6 letter P's. the dash has shut down and no longer works, and it's only since the battery went flat two days ago. any
advice would be great. many thanks to whoever can help.,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How did you charge up? Any chance of overvoltage?
Other wise disconnect battery, wait ~5 mins and reconnect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

done that, left it off over nite, also had the dash unplugged for over an hour as well but no luck :(
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Maybe this gives a solution: http://forums.bimmerforums.com/forum/showthread.php?tR5569
Best regards, Marcel, '92 525i @ 347000 Km

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It might help if you stated the model and year. Older cars have a memory backup battery which fails.
--
*You can't teach an old mouse new clicks *

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.