Dead E30

Earlier today, after running perfectly for months, my 1991 318is died. It would not turn over but all the power items (windows, etc) worked... if a
little slow. Jumped it and it started right up and drove the 1/4 mile home. haven't had it back out. I of course suspect the alternator so was wondering if there is a way to check it on the car or if I need to take it some where... or if there is something else entirely I should be looking at. thanks
Matt
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
. or if there is something else entirely I should be looking at.

Have the battery checked first.
Joe
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Much more likely to be the battery. The give little warning of failure.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
John Burns wrote:

i had the same problem w. my '90 535i. It just needed a new battery.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Battery tested bad, so replaced it and it ran great all day yesterday.. today, same problem... Alt is next. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.