Do I have Faulty Ignition System ????? 1990 325is

I am a mechanical novice.
My car starts and idles well, but has poor acceleration and power.
I guess the first thing I should do is hook a plug wire up to a new
sparkplug and see if the spark is blue or yellow. If it is yellow, then some component in the ignition system is not working right.
I want to keep this easy.
Maybe I should just assume that it is my rotor and cap, and get it changed.
I know I can use a multimeter to check the OHMs on the ignition coil (How often do coils go bad?)
If my spark is a nice healthy blue, could my problem be caused by timing?
The problem has gradually become worse. It used to hesitate only when the engine was cold. Now it hesitates and has power loss all the time. Makes me think the rotor has worn out.
I am a novice, but have the Bentley Manual.
Any ideas?
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ben wrote:

Before you look at fuel and ignition and stuff I would suggest you look at your exhaust. A blocked exhaust would give exactly the simptoms you describe.
Otherwise, there are alot of things to look at if you are losing power. Firstly even though 17 years old your car has a fairly modern design. The fuel delivery and ignition are all cotrolled by the central computer ( the ecu ). There is not a lot that you can actually adjust. I would start by a little basic servicing. get your self six new plugs, a new rotor arm and a new distributer cap. A big culprit could be your air filter so a new one of these may help ( test this by driving around without it for a SHORT while.) A new fuel filter would be a good idea - these get overlooked on older cars and can become blocked if your fuel is poor. Coils tend to fail catastrophically rather than partially but each case is different so I wouldn't like to say here.
But get someone to look at your exhaust first.
hope you fix it soon.
Dave.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.