dodgy car speaker wiring

Hi all
Its a UK 91 E34
Standard 4 speakers around the car, some previous owner added a cd player unit in the dash.
Now when i go over bumps, sound drops to maybe 1 left speaker, or 2, so
thats none at the back, another bump might put sound to all 4....this happens all the time, so i guess it would be a dodgy bit of wiring.
Where would i start to look? I have no idea how BMW wired up the car.
many thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 08 Aug 2006 07:16:40 GMT, "Jules"

I would suspect it's not the BMW wiring, but how the guy who installed the CD player has connected into it...
Start by pulling out the CD player, and checking how it's connected into the BMW loom.
Connector blocks a good, twisted wires lacking insulating tape are bad!
If all looks good there, check the connectors onto the bottom of the rear speakers, sometimes they can get a bit loose with age, and a quick squeeze with a pair of pliers works wonders.
Dodgy.
--
MUSHROOMS ARE THE OPIATE OF THE MOOSES

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
waffled on about something:

Ok will try that, i never had a car stereo in 9 years, preferd the sound of the engine, and before that they were all standard and fine for what i neeed
ta!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.