E30 still dead

'91 318is
Symptoms in review: Car runs great for a day, and then the next day after several miles (say 25-30) of driving, the battery goes dead and the car
quits. Battery tested bad and was replaced, same result. Today I took the alternator off and had it tested and everything came up green... Where else do I look? It is the bosch alt so the regulator is internal... Just don't know where else to look. thanks.
Matt
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
when the car is running -- how many volts at the battery terminals?
Broken wires from the altenator back? Fuses?
wrote:

--- AntiSpam/harvest --- Remove X's to send email to me.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ok, i had similar problem last winter, batt was at least 6 yrs so i figured it was on borrowed time anyways and changed it...2 days later same prob. Grabbed $10 voltmeter, recharged new battery, tested batt with car off, read about 12.6 vlts, started car tested batt again, it read 13.9( figured alt/reg was good, it was charging ok). Shut off car opened hood and went through fuse box 1 by 1 reading any draw off a possible open circuit. Found 1 , i think fuse 4?? was letting thru 3.46 vlts.WTF? disconnected aftermarket radio, checked again, same. Now figured i got a short somewhere draining batt. Talked to mech friend and he said...old bmw, electrical prob, l$o$l... Came home that night, backed car into garage, was walking around to get plug in and noticed a slight light coming from trunk. Loooked again and i sure i could see light thru the crack of my somewhat bowed/misaligned trunk. LAughed when i realized that my trunk light apparently has been on for days and draws about 3 vlts. Problem solved. You'll be real real real lucky if u got same prob lol, but similar testing should narrow it down some, net search should give u fuse diagram if you don't have one,post back after a lil investigation post battery draws/at each fuse as well as at the batt and i'm sure one of the experts can help solve prob or at least give u somewhere to look. g/l
Matthew Warren wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did your car quit while running? Because the battery always starts out strong when I get in the car (after charging) and then slowly dies as I drive.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
so, like, what did your batt read after fully charged, not hooked to car? so like what did it read after connected to car, not started? same question + 1hour...take a break were going at it pretty hard lol? so like what did it read when u started car at idle, was it charging? g/l d
Matthew Warren wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.