E36 fan speed erratic

Hi,
The a/c fan on my 323i touring seem sto have a mind of it's own, does anyone know what the problem might be?
FWIW I am in the UK and the car is a 1998
Many thanks in advance,
Jon E
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Likely the final stage resistor. You should find fitting instructions on one of the specialist sites. Costs about 50 gbp, IIRC. I'm on the third on my E39.
--
*Dancing is a perpendicular expression of a horizontal desire *

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
London SW

Hi Dave,
Thanks very much for that, are there any sites you can recommend? Or anywhere to get the aforementioned part - do I need a new one or can I find a re-conditoined one?
Many thanks,
Jon
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

All mine were supplied under warranty. I'd say it's dealer only, but you might try Eurocarparts. It's not repairable IMHO
Think John Burn's site will give most of the links.
http://www.unixnerd.demon.co.uk/bmw.html
--
*Why do the two "sanction"s (noun and verb) mean opposites?*

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
London SW

Thanks very much again! Most appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jon E wrote:

Yep, a common problem...had it myself a couple of months back. Someone here gave me this: http://macadamizer.com/bmwfix .html
I followed the directions on the site for replacing the bad capacitor, and the motor's worked like a dream since!
-- Cliff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for all the replies, most appreciated. Problem to be sorted soon - thanks very much!
Jon E
Jon E wrote:

Yep, a common problem...had it myself a couple of months back. Someone here gave me this: http://macadamizer.com/bmwfix .html
I followed the directions on the site for replacing the bad capacitor, and the motor's worked like a dream since!
-- Cliff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.