E36 wont start

Hi,
I have a 96 328i
About 4 weeks ago the Airbag check light came on. Hadn't yet had a chance to look at it. Then 2 weeks ago the horn started to fail intermittently, and then died
completely. Then today while driving I noticed the Fuel & temp gauges went dead. However the car drove fine Reached my destination & switched off. An hour later tried to start the car, ignition goes on but starter doesn't turn, engine's totally dead. Also it was raining & I had the wipers on. When trying to start now, although wipers in off poistion the wipers came on randomly, yet not starting. With ignition on the air flow meter's also making a buzzing sound. Is this normal?
Any ideas
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How can it be normal if your car is like this?
Do a dash check to see if the little motor for the gauges are faulty Turn off your key (position 0), then press and hold the trip milage reset button, while holding it in, turn the key to position 1 then release the button. Wait a while then all needles should move.
Do that first and post your result and go from there....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like something either in the alternator or voltage regulator...at least thats where I would start.. Can you get OBD codes? There is a pattern, turn key, press pedal down 5 times or something and then count the flashing check engine light. Do a google search.. Im sure you will find it. The car should not be started to do this test and you already have that covered.. ;) Good luck!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Corey Shuman wrote:

I have a '96 328i as well. It's my understanding that this car has OBDII and you can't get the codes in the way you describe. I ended up getting the Peake diagnostic thingie...
Karl Winkler http://www.karlwinkler.com/Giovanni.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The car is OBD II Compliant, this means you can go to AutoZone and get the code reader to read what the computer is complaining of.
It sounds to me like you have lost ground somewhere though, and I'm not sure if this will show up in the codes.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.