E39 Windscreen water squirters not working

My water ran out today during a long, foggy, dirty drive and now that I have re-filled the tank they are still not working. The squirters on the headlamps are working.
Any ideas what's causing this / how to fix it...?
TIA
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Mine did the same the other day. One of the pipes to the jets had blown off. Just pushed it back on and all OK.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Did that knock out all 4 jets...? The separate soap spray works fine BTW...
Is it easily accessible under the bonnet? (I'll go out and take a look now!)
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes very, you may have to pull back the sound insulation. It slots into the metal work. If it has been leaking it will be sodden with washer fluid!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Just had a look, and listen and it sounds like the problem is at the other end, the pump fires but it is a very dry sound, as if the water is not even getting that far!
I'm looking at my Haynes right now to see how to get at it...
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

blimey, not a job for 9.30 at night then!
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Thanks BTW ! ;-)
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

also, after reading the BMW manual properly for the first time (only had the motor 2 months) should I be putting proper BMW Intensive Wash stuff in the other pot or can I just put in any old concentrated screen wash?
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not sure. Depends on age of car. Mine is 1998 and I use Halfords screenwash with no probs.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

It's a 2000 with a separate pot for "Intensive" wash !?
--

Shevek

iTunesRegistry.com: 4,199 tracks, 2.968 diversity
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Air lock (most likely), suck the s**t out of the bottom of the tank and blocked the pipes / jets, motor blew when it overran in air...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.