E46 ASC light then EML light coming on

10 days ago the ASC light came on then about 2 seconds later the EML light came on my dashboard and the car went into limp home mode. Stopped the car
and waited about 10 minutes then restarted all fine, about an hour later both lights came on again in the same sequence. Parked up overnight and the lights did not come on again the following day or the next 8 days and I thought I was in the clear but then they came on again. Back off now, but I expect them to come on again.
I am hoping this might be a faulty sensor and not something more expensive. Anyone experienced the same or got an idea what might be wrong? I suppose the next step is to have a diagnostic. The car will be eight years old in March. I think it is on the original battery as I have owned the car now for the past 4 years and three months and it has not been changed in that time. The car had some new brake pads fitted on the front when it was MOT'd in September and the sensors did not need replacing and I watched them do it. I do not think the problem could be the new brake pads as all has been fine since the MOT until now. The car has only done 59K and is in great condition and been well looked after.
One more thing I should really take the car in for a service as it is 18 months since the last one, but is still showing 7K until it needs doing.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Blown ABS Sensor?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hopefully it is something simple like this, however would a blown sensor bring on the engine management light two seconds after the ASC light comes on? Also the lights comes on occasionally then might be off for days. Maybe a failing sensor rather than blown or something else?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mick wrote:

Question - you don't have an aftermarket iPod link (IceLink) installed by chance? These are known to cause confusion on the car's computer bus and can cause odd things like this to happen.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

No car standard apart from BMW optional extras like CD player. Nothing new added or done recently apart from brake pads but that was about four months ago and the car has been fine until now.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.