e46 coupe reversing sensors problem

Hi,
2002 model, UK. A week or two ago the reverse radar sensors started acting up for no good reason that I could see. As soon as I put the box into
reverse the sensors bleep very fast even when there's nothing at the back of the car or around the rear quarters.
Could someone have hit the car on the rear bumper without me knowing and upset them?
I'd be grateful for any help on this, otherwise it's a trip to the dealer and get the car connected to the expensive (to me!) computer.
Ta
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
John wrote:

The fast bleep is to let you know SOMETHING IS WRONG.. most likely one of the sensors has been killed. Bummer 'cause they are expensive and it wouldn't pay to just start replacing them without knowing which one it is (which requires a trip to the dealer to have their computer read it out..)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Ah well, I thought a trip to the dealer was probably on the cards!
Ta
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
John wrote:

One thought since you are in the UK - you might check around for an independent shop that has the AutoLogic diagnostics box. The AutoLogic does have the needed code to diagnose the sensors and the private shop may be less expensive than the dealer. The AutoLogic is from the UK, so I expect it may be more easily found there.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.