E46 issue with ABS & ASC lights

Hello my fellow bimmers.
I wonder if someone can shed some light to a recent issue I'm suffering with my 2000 323Ci (e46). The ABS & ASC lights go on when it rains!! If I
put the car in the garage and let it stay until the next day, if the weather is bad (raining) those warning lights will turn on.
Ok, it seems like a simple fix, either a weather seal or the sensor housing is cracked and lets in water? right? I'm unsure if its fixable, or would I have to change the sensor.
I'd like to do this myself, is it hard? Anyone have recommendation for order parts? Or should I visit BMW for the part? Also, how do I know which wheel sensor is bad? I figured a pressure washer on a dry day, with trial and error can be a method... But it seems dumb to try... better yet should I change all 4?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

They're not that cheap. It sounds more like a bad connection to one of them. ASC uses the ABS sensors.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hook you car up to the OBD computer and read the fault codes. That should tell you which sensor is bad.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 13 Oct 2005 10:52:29 -0400, snipped-for-privacy@sticklocal.com wrote:

Interesting. I get intermittant ABS/ASC fault-lights on my 2000 323i. Sometimes it goes-away for a month, only to return again. I have not noticed that it's related to water, but I'll keep that in mind from now on.
Just today, it was diagnosed at the shop as my LR "wheel speed sensor" (ABS sensor). I was told that it should be about $350 to replace, but that "sometimes" they can't replace it without also replacing the entire wheel/hub assembly, which would add $600 to the bill. I passed, for now, thinking that I can take a look myself, now that I know which corner is the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.