E46 windscreen washer filter clean?

Hi,
Anyone taken the tank out and found the filter and cleaned it (and obviously reassembled!)? My washers are playing up. Mostly they only squirt the water just above the wipers (this has only happened a week
or so ago) but then they worked ok for a couple of days, now they are back to being puny. My guess is the small filter somewhere in the tank/ pump system.
Has anyone had this problem and found a solution?
Ta.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
They sell the pump at NAPA, and other fine parts retailers. Me thinks you need one.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Is it freezing where you are?
Are the nozzles clogged?
Then try washing out the tank, filters and pump in that order.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

It's working then not so I think there's something in the system being forced towards the jets, then seems to drop back and then forced forward again. I'm going to clean the fronts of the jets and then put clean hot water though the tank, pipes and jets and see if that makes a difference.
It's not the pump - it works and I can hear it working even when the water only just comes out.
John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Clean out the nozzles too (probably first).

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

.
On my X 5 there is a filter (connected to the pump) inside the washer tank. I pulled the pump out (rubber grommet holds it in place) and the filter was covered in gunk. Wased the gunk off and now they work fine.
gw
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yeah - found the same - grommet below the pump has the filter attached, easy to pull out and clean works great now. The tanks has black sludge in it - any idea how to clean it out without taking out the tank?
Ranger
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.