German Spec 1992 316i

I am new here, however, I currently live in Germany and own a 1992 316i. Over the past few weeks I noticed my car "sputtering" at take off in 1st gear. Last week, it started doing
it in 2nd gear, up to about 3500 RPM (give or take) then it doesnít "stutter" so much, and rarely if ever "sputters" in 3rd gear or higher. I thought that maybe I had a bad spark plug, so I changed all of my plugs and wires, nevertheless it is still sputtering.
Now, I only live about 10 minutes from work and my car doesnít "sputter"until it is warmed up (the gauge reads halfway between cool and hot). At this point I am thinking that it may be a fuel problem; Maybe the injectors? The car is 13 years old, but only has 162,000 kilometers on it. Do I need a good cleaning of the injectors? Fuel filter? I donít know at this point, but if it is something that I could fix myself that would probably be a good thing to know. Thanks all who read this and I appreciate any comments that anyone can send!
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.