Headlights + Turn Signal = High Beams?!

I recently purchased a 1992 525i 5-speed. With the headlights on, flipping the turn lever down (to signal left) makes the high beams turn on. This does not happen when the lever is pressed down before the
detent (as if I were changing lanes) and does not happen when the lever is pulled up to turn right. Has anyone dealt with this before?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
blee wrote on 31 Jul 2006 20:35:40 -0700:

I've had this before on my E36 - and then realised it was my fault. At the bottom of the anti-clockwise stroke I was nudging the lever forward which puts on the high beams. I know it sounds patronising to ask, but are you sure you're not knocking it slightly forward?
Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Spack wrote:

I went out to my car last night to investigate further. It turns out that the signal lever has enough play in it now, such that it rocks forward just slightly when it's fully depressed -- enough to touch the contact for the high beams. Pulling back on the lever (as if to flash my lights) a very, very small amount is sufficient to make it go away. Sounds like I need a new switch in there.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.