Idle Problem - 320I

I have a 1992 320I (European spec) and the idle seems to oscillate up and down when in park. When put in gear and the brake applied it will stall out.
Any ideas.
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It'll be a vacuum leak or a bad O2 sensor.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 525i had idle problems for over 4 years. replaced everything, O2 sensor, hoses, swapped many parts with its twin sister but to no avail... I took the Idle Control Valve (ICV) out sprayed some CRC 556 into it cleaned it thoroughly (BE CAREFUL - as there are electrical components in there as well, don't use anything that is going to corode the electronics). Free the valve inside by rotating with finger a few times, dry it out and put it back in. Fixed in an instant. She starts without pumping the gas and idles like a kitten for the first time in almost 5 years.
See following link
http://www.mesaperformance.com/faqs/idle.html
John G.Burns B.Eng, Bonny Scotland

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.