Ignition and electrical problems

Hi I have a 96 bmw 316 which has been giving me grief for a few weeks now When i go to turn ignition i just get this clicking noise with the odd wurr for about a minute, all the lights on the clock face start going
crazy, flashing on and off, first with time, then random temperature, then random mpg, then random time, etc etc, you get the picture, this is all before the car actually starts, i call it the warm up mode, after approx a minute (but it is getting longer) the car will actually turn over and start, it is ok for the rest of the day until left a reasonable amount of time turned off, then i have to start my warm up again. When the car is running fine i've noticed that the mileage counter is not lit up and some other lights (gauges) seem to be unlit or missing. I have looked for loose wiring but found nothing, I am thinking that fuses may have gone but recently opened the fuse box to find tens of fuses and quickly closed it again, could i be getting a short circuit somehow, any clues much appreciated, cheers Tel
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 15 Apr 2006 18:07:30 -0400, tel3563 wrote:

Could be anything from your starter:
http://realoem.com/bmw/showparts.do?model=CG21&mospidG451&btnr _0301&hg&fg%
To your ignition coil:
http://realoem.com/bmw/showparts.do?model=CG21&mospidG451&btnr _0575&hg&fg
But you have other electrical anomalies, so I'd suggest bringing it into a bmw shop- not a dealer. Join the bmwcca(http://216.27.82.195 /) and find a shop in your area that does bimmers and gives you a 10-20% discount for the bmwcca memebership. Good luck.
ER
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.