Loss of power on my 1998 V8 540i

I have got a 1998 V8 540i
The problem started that it lost power when you used the kickdown it was almost like it was in the wrong gear, my local mechanic put it on
the diagnostic and said that it was showing cylindar block problem, he found that four coils were loose and he replaced one ignition coil and a set of plugs, the diagnostic then showed no faults.
He gave us the car back, we did two journeys and the problem started again but with all accelerating, it just seems to have lost all power.
The machanic said that there seems to be a lot of pressure in the water system but he doesn't know why
We did have the radiator replaced a few months ago as the top (moulded) hose joint thingy had split, when they took the radiator out they said that it was distorted/blown out of shape but I don't know whether it is relevant to the current problem.
Any advice you can give me would be great
Thanks
Cass
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Cass wrote:

If there really is high pressure in the coolant, not attributed to having hot coolant, then that points very strongly to a cylinder head gasket failure or indeed a cracked head. Any quarter decent mechanic would think the same.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Cass wrote:

. .
Uh, were there lots of dogs and cats in the "customer waiting area"? Maybe a bird or two?
That's not a mehcanic, that's a vet.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.