My 535 has stopped surging and now has died.Please Help

My 535 that I was talking about with the surging just stopped the other day. I drove to a place across town and walked out and it just wouldn't start.
Had to get it towed home. Now it has no spark it has power to the coil and the crank position sensor seems to have the right resistance so it seems to be working. Any suggestions?
Thanks
Damien
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

1989 - check the obvious and if no joy scrap it an buy one ten years younger (at least).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My 525e did a no-start once. It was getting a spark and I couldn't see the problem. It was a bad solder joint on the Motronic DME's main output resistor, the spark was there but was really weak.
Are you getting fuel?
You'd not get a spark if the sensors weren't connected.

Why? The E28 is much better looking and has lees to go wrong. That car has years of good use left :-)
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.